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1 Starting Out

1.1 Install the TinyTERM Emulator
The TinyTERM installation now includes four different installation 
types: TinyTERM PLUS Desktop Install, TinyTERM PLUS Thin Cli-
ent Server Install, TinyTERM PLUS Web Client Desktop Install, and 
TinyTERM Desktop Install.

Before installing a TinyTERM emulator, you must remove any older 
versions that you have installed. If you are evaluating multiple Ti-
nyTERM product installations, you must remove one before evaluating 
another. To uninstall a TinyTERM product, back up your keyboard.
dat file and all .tpx files by copying them to a temporary directory or 
to a floppy disk. Then refer to section 1.2 “Uninstall the TinyTERM 
Emulator” for instructions on how to uninstall the current TinyTERM 
product.

To install the TinyTERM emulator, follows these steps:

 1. Close all Windows applications.
 2. Installation can be done from either CD-ROM or from a 
  downloaded executable.

Installing from CD-ROM:
Insert the CD-ROM in your CD-ROM drive. The TinyTERM installa-
tion program should start automatically. If it does not, open the CD-
ROM folder and double-click on the SETUP.EXE program.

Installing from an executable:
Locate the executable on your system and double-click on it. The Win-
Zip Extraction dialog will be displayed. To extract the installation files 
and launch the installer, click on Setup.

 3. The TinyTERM Product Family Setup dialog should now be 
  displayed. After reviewing the installation information displayed 
  on the dialog, click Next.
 

3
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 4. The software license agreement is displayed. Read the agreement 
  (use the PgUp and PgDn keys) and click on Yes to indicate your 
  agreement to the software license and to continue with product 
  installation.
 5. The Installation Type dialog is displayed. If you’ve purchased a 
  TinyTERM product, select it from the list and click Next. If you’re 
  evaluating a TinyTERM product, select the product you’d like to 
  evaluate and click Next.
 6. The Product Registration dialog is displayed.
 
If you’ve purchased a TinyTERM product:
Enter your name, organization (if applicable), your serial number, and 
activation key. Once you’ve verified the serial number and activation 
keys are correct, click Next.

If you’re evaluating a TinyTERM product:
Enter your name and organization (if applicable), and then click 
30-Day Eval.

 7. The  Destination Location dialog is displayed. You can choose the 
  default destination folder (recommended), or click on Browse to 
  select another location for the product files to be copied to. 
  Click Next.
 8. The Program Folder dialog is displayed. You can choose the 
  default program folder (recommended), or select another program 
  folder from the list. Click Next.
 9. The TinyTERM files will be copied to your system. As the files are 
  copied, progress messages are displayed as the installation 
  program installs the TinyTERM emulator into the destination 
  folder. Other system resources are updated (such as the registry), 
  and entries are added to the Start button.
 10. When the installation has been successfully completed, the 
  Setup Complete dialog is displayed. To exit the installer, click 
  Finish. If you installed from a downloaded  executable, the 
  WinZip Extraction dialog will disappear after a few moments.
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1.2 Uninstall the TinyTERM Emulator
 1. Click the Start button, point to Settings, and then click 
  Control Panel.
 2. Double-click Add/Remove Programs.
 3. In the scroll box, click the TinyTERM emulator product that you 

want to remove.
 4. Click Add/Remove.
 5. Click OK to confirm that you want to remove the TinyTERM 

emulator.
 6. Restart your system.

1.21 Uninstall the Century LPD Server  
(Windows NT, 2000 or XP only)

 1. In the system tray, by the clock, right-click the hammer and 
wrench icon.

 2. From the popup menu, select Stop CenLPD.
 3. Click the Start Button, point to Settings, and then click 
  Control Panel.
 4. In the scroll box, select NetUtils, and click the Add/Remove 

button.
 5. Click OK to confirm that you want to remove the Network 

Utilities.
 6. Restart your system.

1.3 Start the TinyTERM Emulator
 1. Click the Start button, and point to Programs.
 2. Point to the TinyTERM emulator folder, and click on the 

TinyTERM emulator.

1.4 License the TinyTERM Product
Use the License Manager program to register an evaluation version of 

the TinyTERM product.
 1. Click the Start button, and point to Programs.
 2. Click the TinyTERM emulator folder, and then click 
  License Manager.

5
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 3. Choose the suite based on your serial number.

Your serial number starts Choose this suite

S42
TinyTERM Web Server 
Edition

P42 TinyTERM PLUS Edition
E42 TinyTERM

 4. Click Upgrade.
 5. Enter your serial number and activation key.
 6. Click Update License.
 7. Click Close.

1.5 Install NFS (not available in the downloaded .exe)

Century Software provides an NFS solution with the TinyTERM PLUS 
Edition emulator. Since most customers do not need an NFS solution, 
the TinyTERM installer does not automatically install NFS. Before you 
can install the NFS solution, you must install the TinyTERM PLUS 
Edition emulator. (Note: NFS is only supported on Windows® 9x, and 
NT 4.0)

 1. Close all Windows applications.
 2. Insert the CD-ROM in your CD-ROM drive. If the TinyTERM 

installation program starts automatically, click Cancel, and then 
click Exit Setup.

 3. Click the Start button, and then click Run.
 4. In the Open box, type the following text:
  D:\nfs\setup.exe
  Note: If your system has assigned your CD-ROM drive a different 

drive letter, substitute that letter for D.
 5. Click Next. You see progress messages as the installation program 

installs NFS.
 6. Click Finish.
 7. Restart your system.
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2 Connections

2.1 Planning a Connection
Before using the TinyTERM emulator to make a connection to a 

remote host, you need to know the following:
• Whether you will connect to the host via a network, modem, or 
 direct serial connection.
• The emulation (such as Wyse 60 or VT100) the host accepts.
• For each connection type, you need details about the connection.

If you  
connect via

You must know

Network The host’s IP Address or host name
Modem The host modem’s phone number
Serial The correct COM port, connection 

speed, parity, word size, and stop bits

If you are unsure of any of this information, please contact  
your network administrator, who can provide the necessary  
information.

2.2 Make a Network Connection
 1. On the Edit menu, click Session Properties.
 2. Under Connection type, click Telnet, rlogin, SSH or SSL/TLS.
 3. In the Emulation list, click the emulation supported by your host.
 4. In the Host name, IP address, or phone number box, type the 

host name or IP address
 5. For rlogin, click the login tab.
  Enter your username in the username box.
 6. Click OK.
 7. Click Connect.

2.3 Host Key Authentication
This procedure will guide you through associating a private key with a 
given session. An introduction to host key authentication is beyond the 
scope of this guide.

7
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 1. Open the Session Properties dialog, and select the Login tab.
 2. At the top of the dialog, select the Use Private Key checkbox.
 3. Click on the Load Private Key button. This will present a 

standard file browsing dialog from which you can select the 
private key to associate with this connection. Select the key file, 
and hit OK. This key file will be referenced by the .TPX file 
directly, and should be kept on the same place on your computer.

 4. Apply the settings and exit the dialog.
 5. Connect to your host.
 6. When connecting, you will be asked for your private key password to 

decrypt the key file. This password is not stored (for security reasons) 
in any way: it must be entered when connecting every time.

 7. If the key is accepted by the remote host, you will be 
automatically logged in. If it is not accepted, in most cases a 
dialog will be presented asking for a login and password. In 
certain setups, this secondary login method is barred from 
use – in which case, an  error dialog will be displayed, and the 
connection will be refused.

2.4 Make a Modem Connection
 1. On the Edit menu, click Session Properties.
 2. Under Connection type, click Modem.
 3. In the Available Devices list, click the modem for this connection.
 4. Under Available Devices, click Setup. The Modem Setup dialog 

box appears.
 5. Click Configure. The modem properties dialog box appears.
 6. Set the Maximum Speed that matches the speed of the host’s modem.
 7. Click OK to close the modem properties dialog box.
 8. Click OK to close the Modem Setup dialog box.
 9. In the Emulation list, click the emulation supported by your host.
 10. In the Host name, IP address, or phone number box, type the 

phone number, including any dial-out prefix and area code.
 11. Click OK.
 12. The modem setup dialog appears. Click OK.
 13. Click Connect.
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2.5 Make a Serial Connection
 1. On the Edit menu, click Session Properties.
 2. Under Connection type, click RS232 (Serial).
 3. In the Available Devices list, click the COM port for this 

connection.
 4. Under Available Devices, click Setup. The RS232 Setup dialog 

box appears.
 5. Set the Baud rate, Parity, Word size, Stop bits and Flow control.
 6. Click OK to close the RS232 Setup dialog box.
 7. In the Emulation list, click the emulation supported by your host.
 8. Click OK.
 9. Click Connect.

3 Settings

3.1 Map a Single Character to a Key
 1. On the Edit menu, click Session Properties.
 2. Click the Keyboard tab.
 3. Click Edit. The Edit Keyboard Map dialog box appears.
 4. Drag the result key onto the key you want to produce that result. 

For example, if you want F12 to produce the letter “a,” drag the “a” 
key onto F12.

 5. Repeat step 4 for each key you want to remap.
 6. Click OK to close the Edit Keyboard Map dialog box.
 7. If you want to save the changes to the keyboard map for use in 

another session, click Save As, and then enter a name for this 
keyboard scheme.

 8. Click OK.

3.2 Map a String to a Key
 1. On the Edit menu, click Session Properties.
 2. Click the Keyboard tab.
 3. Click Edit. The Edit Keyboard Map dialog box appears.
 4. Click the key to which you want to assign a string.
 5. In the Action list, click MACRO.
 6. Do one of the following:

9
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 • Type the string into the Value box.
 • Drag keys from the keyboard to the Value Viewer box.
 7. Click Set.
 8. Repeat steps 4–7 for each key to which you want to assign a string.
 9. Click OK to close the Edit Keyboard Map dialog box. 
 10. If you want to save the changes to the keyboard map for use in 

another session, click Save As, and then enter a name for this 
keyboard scheme.

 11. Click OK.

3.3 Change the Background Image
 1. On the Edit menu, click Session Properties.
 2. Click the Background tab.
 3. Click Browse.
 4. Select an image file such as one of the sample backgrounds 

installed with the TinyTERM emulator or with Windows®.
 5. Click Open.
 6. Under Background Image, select one of the options.\

Choose To display the image

Fit to screen Stretched or compressed to fit the window

Tile Repeated to fill the window

Center Centered in the window

 7. Click OK.

3.4 Change Display Attributes
 1. On the Edit menu, click Session Properties.
 2. Click the Attributes tab.
 3. In the Mappable attribute combinations list, choose the 

attribute that you want to change.
 4. In the Display attribute as box, select or change any display 

options. As you make changes, the results appear in the Preview 
window.

 5. Use the Foreground color and Background color lists to select 
the colors you want for this attribute.

 6. Repeat steps 4–6 for each additional attribute you want to change.
 7. Click OK.
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3.5 Change the Code Page
 1. On the Edit menu, click Session Properties.
 2. Click the Code Page tab.
 3. Choose the code page for incoming data in the Receive code 

page list.
 4. If you want to use the same code page for transmitted data, select 

Join transmit and receive code pages; otherwise, choose the 
code page for outgoing data from the Transmit code page list.

 5. Choose the code page for data you type in the Keyboard code 
page list.

 6. Click OK.

3.6 DBCS
TinyTERM supports the use of the following DBCS standards: 
GB2312-80 and Big5 for Chinese, KOI-8 for Korean, and ShiftJIS for 
Japanese. In addition to these regional standards, UTF-8 support 
is present for universal language support. By default, none of these 
decoding methods are active. To use them, perform the following  
procedure.

 1. Open the Session Properties dialog, and select the Code Page 
tab.

 2. At the very bottom, select from the drop down box labeled DBCS 
the decoding method you wish to use.

 3. On the Fonts tab, add an appropriate Unicode font, move it to 
the bottom of the list, and select the Unicode Font code page 
from the drop down list on the right. Please see the Font section 
of this guide for more information on adding and deleting fonts.

 4. Apply the settings and exit the dialog.

3.7 Save Custom Settings
You can save any changes you make to the session properties to a 
TinyTERM emulator session properties file (a .tpx file). Once you 
save the settings, you can load the settings from the file to restore your 
preferences.

 1. On the File menu, click Save As.

11
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 2. Type a file name for your settings file.
 3. Click Save. 

3.8 Change the User Interface Language
TinyTERM™ has the ability to change the user interface language for 
menus and dialogs on the fly. To change the user interface language, 
do the following:

 1. On the View menu, choose Language.
 2. Choose a language from the choices presented.
 3. The user interface will now display menus and dialogs in the 

selected language.

4.0 File Transfer and Data Capture

4.1 Send a File
For most file transfer protocols, you must start a host application in 
receive mode before sending a file to the host.
 1. On the Tools menu, click Send File.
 2. In the File transfer protocol list, choose the protocol for this file 

transfer.
 3. In the Remote host name box, type the remote host’s name or IP 

address.
 4. If you want to send the file to a directory other than the current 

directory on the remote host, enter the destination directory in 
the Remote host’s receive directory box.

 5. Under Transfer type, choose either ASCII or Binary.
 6. Drag the file or files you want to send from the Available files box 

to the Local files to send box. Note: Some transfer protocols do not 
support multiple file transfers.

 7. Click Send.
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4.2 Get a File
For most file transfer protocols, you must start a host application in 

send mode before receiving a file from the host.
 1. On the Tools menu, click Get File.
 2. In the File transfer protocol list, choose the protocol for this file 

transfer.

 3. In the Remote host name box, type the remote host’s name or IP 
address.

 4. If you want to save the file to a directory other than the current 
directory on your machine, enter the destination directory in the 
Local destination directory box.

 5. Under Transfer type, choose either ASCII or Binary.
 6. In the Source files to get box, type the name or names of the files 

you want to receive. Note: Some transfer protocols do not support 
multiple file transfers.

 7. Do one of the following:
 • Click Get File to initiate a file transfer from the remote host.
 • Click Receive File to begin receiving a file for which you have 

already started the transfer from the remote host.

4.3 Configure Data Capture to a File
 1. On the Edit menu, click Session Properties.
 2. Click the Data Capture tab.
 3. In the Capture device list, click FILE.
 4. In the Capture file or device name box, type the name of the file 

to which you want to save captured data. Note: If you use the “#” 
symbol in the file name, the TinyTERM emulator will consecutively 
number each new capture file. For example, the file name Capture#.
txt produces the series of files Capture01.txt, Capture02.txt, and so 
on. The TinyTERM emulator creates the data capture files in the 
current directory unless you specify a full path in the Capture file or 
device name box.

 5. Under Capture file creation, select Append or Overwrite.
 6. Click OK.

13
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4.4 Configure Data Capture to a Windows Printer
 1. On the Edit menu, click Session Properties.
 2. Click the Data Capture tab.
 3. In the Capture device list, click PRINTMGR.
 4. Click OK.

4.5 Start Capturing Data
 • On the Tools menu, click Capture file. If you have the Session bar 

visible, a moving butterfly net appears.

4.6 Stop Capturing Data
 • On the Tools menu, click Capture file.

5 Printing

5.1 Print Directly to a Network Printer
 1. In the File menu, click Printer Setup. The Printer Setup dialog 

box appears.
 2. Click To Windows printer.
 3. Select the printer from the drop-down list.
 4. Click OK to close the Printer Setup dialog box.

5.2 Print Directly to a Local Printer
 1. On the File menu, click Printer Setup. The Printer Setup dialog 

box appears.
 2. Click Direct to device.
 3. In the Direct Device Name box, type lpt1: or the correct port 

for your local printer.
 4. Click OK to close the Printer Setup dialog box.

5.3 Configure LPD Printing (Windows® 98, or Me)

LPD makes your PC printer available to UNIX systems.
 1. Open the Network control panel.
 2. Click Century Internet Services.
 3. Click Properties.
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 4. In the Service Name list, click printer.
 5. Click Enable.
 6. Click Configure.
 7. Click New.
 8. Type the printer’s name. This name must be exactly the same as 

specified when setting up a remote printer on the UNIX host.
 9. Click OK.
 10. Click on the new printer, and click Connect.
 11. Choose a printer driver for the new printer, and click OK.
 12. If you want to set up a specific spooling directory, click the 

Spooling tab, clear Use local machine Temp directory, type the 
directory in the Path box, and click OK. (Include a trailing \ on the 

directory; e.g., C:\Spool\)

 13. Click the Access Rights tab.
 14. Click Add.
 15. Click Any Host, or type a machine name and click OK.
 16. Click OK.
 17. Click OK to close the Century Internet Services dialog box.
 18. Click OK to close the Network control panel.
 19. Restart your machine.

5.4 Configure LPD Printing on Windows® NT 4.0, 
2000 or XP
 1. In the System Tray by the clock, right-click on the hammer-and-

wrench icon.
 2. Select Open from the pop-up menu.
 3. Click the New Printer button.
 4. Type the printer’s name in the Print Queue Name box. This name 

must be exactly the same as specified when setting up a remote 
printer on the UNIX host.

 5. In the Windows Printers section, select a printer driver for the 
new printer.

 6. If you want to set up a specific spooling directory, clear Use local 
machine TEMP Directory and type the directory in the Path box.  
(Include a trailing \ on the directory; e.g., C:\Spool\)

 7. Click OK to close the Add New Printer dialog box.
 8. Click Hide to close the Century LPD Server dialog box.

15
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5.5 Configure LPR Printing (Windows® 98, and Me only)

LPR allows PC workstations to use your UNIX printers.
 1. Open the Printers control panel, and choose an existing printer.
 2. On the File menu, click Properties.
 3. Click the Details tab.
 4. Click Add Port.
 5. Click Other, and then click Century Port Monitor.
 6. Click OK.
 7. Type the port name. (for example, hostname!printer)
 8. Click OK, and close the printer properties.

5.6 Configure Transparent Printing
Transparent or pass-through printing enables the host to tell the 
terminal to send data to a printer. For each emulation, the TinyTERM 
emulator watches for certain codes in the data stream from the host.

Emulation On Code Off Code
ADML ESC A ESC B

AT386 ESC [5i ESC [4i

SCO ANSI ESC [5i ESC [4i

TeleVideo 925 ESC ‘ ESC a

VT52 ESC W ESC X

VT100 ESC [5i ESC [4i

VT220 ESC [5i ESC [4i

VT320 ESC [5i ESC [4i

Wyse 50 CTRL+X CTRL+T

Wyse 60 ESC d# CTRL+T

Note: When using the values from this table, you must set the 
correct values for :PN= and :PS= in the /ETC/TERMCAP file 
on the UNIX host. Also, the SCO ANSI console does not sup-
port transparent print; however, the SCO ANSI emulation in 
the TinyTERM emulator does.

The sequence used to turn transparent printing on for Wyse 50 
(CTRL+X) is the same sequence that is used to end the file transfer for 
Z-Modem and WTERMCRC. To have the TinyTERM emulator accept 
the CTRL+X sequence as “Transparent Print On,” change the file 
transfer protocol to something other than ZMODEM or WTERMCRC 
(for example, XMODEM).
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To test to see if transparent print works, do the following:

 1. Create the following short UNIX shell script file and name it 
tprint. Make sure you use the correct escape codes for your 
terminal emulation.

  # Test for transparent print in vt100 mode.
  # \033 is ESC
  echo “\033[5i”
  cat $1
  echo “\033[4i”

 2. Set the permissions on tprint to read/write/execute.
 3. Run the script with a short test file as a parameter.

  tprint file.txt

If the transparent print fails, check the following:

 • The host’s TERM environment variable (it must match the 
emulation you set in the TinyTERM emulator)

 • The values for :PN and :PS in the /etc/termcap file
 • The TinyTERM emulator output setting (it must be set to send 

printer output to the printer and not to a file)

6 Usage Tips

6.1 Create a Desktop Shortcut for TinyTERM
 1. Right click on the Windows desktop, point to New, and click on 

Shortcut.
 2. In the Command line box, type (include the quotation marks): 

“C:\Program Files\Century\TinyTERM\tt.exe”
  Note: If you did not install the TinyTERM emulator to its default 

location, you must type the correct path to the tt.exe file.
 3. Click Next.
 4. In the Select a name for this shortcut box, type TinyTERM 

Emulator or the name you want to use for the shortcut.
 5. Click Finish.

17
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6.2 Start a Custom Setting File from a Shortcut to 
TinyTERM

 1. Right click the shortcut to the TinyTERM emulator, and click 
Properties.

 2. Click the Shortcut tab.
 3. Press the right arrow key to move the insertion point to the end of 

the text in the Target box.
 4. Press the spacebar.
 5. Type the file name of the .tpx file you want the TinyTERM 

emulator to use when starting (such as the Wyse60.tpx file 
supplied with the TinyTERM emulator or a custom settings file you 
have created).

 6. Click OK.

6.3 Use TinyTERM in the Internet Explorer
 1. Start the Internet Explorer browser.
 2. On the File menu, click Open.
 3. Click Browse.
 4. In the Files of type list, click All files.
 5. Double click the TinyTERM emulator settings file (.tpx file) you 

want to open.
 6. Click OK.

6.4 Use TinyTERM in the Netscape Navigator
 1. Start the Netscape Navigator browser.
 2. On the File menu, click Open page.
 3. Click Choose file.
 4. In the Files of type list, click All files.
 5. Double click the TinyTERM emulator settings file (.tpx file) you 

want to open.
 6. Click OK.

6.5 Use the Century FTP Client to Connect to a 
Host

 1. Start the Century FTP client. The Century FTP - Configuration 
Info dialog box appears.
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 2. In the Hostname box, type the remote host’s name or IP address.
 3. In the User Name box, type your user name for the remote host.
 4. In the Password box, type your password for the remote host.
 5. Click Connect. An explorer window appears for the remote 

directory.
 6. Transfer a file by dragging the desired file from its source to the 

destination folder.

7 Scripting

7.1 Create a Basic Script
The sample script below can be used to automatically dial a phone 
number. To implement this or any script, see section 7.2, “Run a 

Script.”
 1. On the Tools menu, click Script Editor.
 2. Click New.
 3. Click CScript.
 4. In the Text box, type the following:
  
  te.xmit (“ATZ\r”);
  te.wait (“OK”, 0);
  te.xmit (“atdt8012683088\r”);

 5. Click Save As.
 6. In the File name box, type Modem.cs, and click Save.

7.2 Run a Script
 1. On the Tools menu, click Execute Script File.
 2. Double click the .cs or .cmd file you want to run.

19
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7.3 Automatically Launch a Post-Connection 
Script

You can have the TinyTERM emulator run scripts automatically before 
starting a session or after closing a session. The example that follows 
uses the script Modem.cs created in section 7.1, “Creating a Basic 
Script,” to send dialing commands to the modem.
 1. On the Edit menu, click Session Properties.
 2. Configure a serial connection (see section 2.4, “Make a Serial 

Connection”).
 3. Select Establish connection on open.
 4. Click Post Connect.
 5. Click Browse.
 6. Click the Modem.cs script, and click Open.
 7. Click OK.
 8. On the Session menu, click Connect.

7.4 Using the Macro Recorder
 1. On the Tools menu, click Macro Recorder.
 2. In the list box, type a name for the macro.
 3. Click the Record button to begin recording.
 4. Type the commands you wish to record.
 5. Click the Pause button to temporarily halt recording and to 

resume.
 6. Click the Stop button to end recording and write the macro file.
 7. Click the Play button to play the macro back.
  See section 7.2, “Run a Script,” to run a macro as a script.

7.5 Using the Hostmode.cs Script
TinyTERM has a powerful script called hostmode.cs that allows you 
to transfer files between PCs. Note: Both PCs will need modems. 
For best results the controlling PC needs to have a modem that will 
accept typed commands. If it has a Winmodem, a modem specifically 
designed to work only with Microsoft Windows, the hostmode.cs 
 script won’t be able to communicate with it properly, and the script 
will fail. An updated version of the Hostmode.cs script is now avail-
able. To download the latest version, please visit our website at  
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http://www.centurysoftware.com/support. Click on the using  
hostmode.cs link. To set up and use hostmode.cs do the following:

 1. On the Edit menu, click Session Properties.
 2. In the Session Properties dialog, change the connection type to 

“RS232 (Serial).”
 3. Under the “Available devices,” select the COM port your modem 

is on.
 4. Then click the “Setup” button next to available devices and set the 

appropriate connection speed based on your modems capabilities.

 5. Once you’ve setup the connection, click the “OK” buttons until 
the Session Properties dialog closes.

 6. Go to the “File” menu and select “Save Session” to save the 
settings.

 7. Go to the “Tools” menu and click on “Script Editor.”
 8. In the Script Editor, click the “Open” button and select the 

hostmode script in the “Open Script File” dialog box. The 
script will open in a separate Notepad window. About 25 lines 
down you’ll see a section labeled, “Variable declaration and 
initial values.” Each line after that has a variable setting and a 
description. These need to be changed to match your controlling 
PC’s requirements. The settings listed in this section of the script 
are fairly common and may work for your modem. But then 
again, they may not. If they don’t work, try to get the correct 
settings from your modem documentation. Most modems come 
with a manual or other documentation that lists the best values 
for these functions. If you don’t seem to have the information, 
gather all the documentation you can for your modem and call 
our technical support for help in setting up the values for your 
modem. The other values in this section are mainly personal 
preference. If you don’t like the setting, feel free to change it. Just 
remember to keep the quotation marks in place, and be sure the 
upload and download directories you choose exist on the PC.

 9. Make any changes necessary to the hostmode.cs script.
 10. Close Notepad, saving the changes.

21
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 11. Click the Run button to start hostmode. Once everything has 
been set up properly, (adding users, setting passwords, etc.) you 
will see a message telling you that hostmode is running.

To connect to the PC running Hostmode.cs, see section 2.3 “Make a 
Modem Connection.”

To send a file to the PC running Hostmode.cs, see section 4.1 “Send a 
File.”

8 Frequently Asked Questions

8.1 Installing TinyTERM
 Q: Why do I keep getting an error that the install has failed due 

to denied access when installing the TinyTERM emulator on a 
Windows NT Workstation machine?

 A: You are trying to install with User rights. You must have 
Administrator rights to install the TinyTERM emulator on a 
Windows NT Workstation machine.

 Q: How can I install the TinyTERM emulator on a machine without 
a CD-ROM drive?

 A: Do one of the following:
 • Copy the TinyTERM CD-ROM to a network drive
 • Download the TinyTERM emulator from  

http://www.censoft.com/download. Install on the desired 
machine and use the License Manager to register.

8.2 Licensing Questions
 Q: After typing my serial number and activation key, why do 

I receive an error that the serial number doesn’t match the 
activation key?

 A: Make sure that you have typed the serial number and activation 
key correctly. The serial number should start with one uppercase 
letter, followed by eight numbers and by the letters EM (for 
example, P42234567EM). The activation should be eight 
lowercase letters (for example, abcdefgh).
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 Q: I have just downloaded and installed the latest version of the 
TinyTERM emulator. When I try to launch the evaluation version, 
why do I get the message that “the license has already expired”?

 A: This often happens when the evaluation version is installed over 
a previous version of the TinyTERM emulator. Uninstall all 
previous TinyTERM versions, restart your PC, and reinstall the 
new version of TinyTERM.

 Q: Can I license an evaluation version without reinstalling the 
TinyTERM emulator?

 A: Run the License Manager. See “Licensing the TinyTERM 
Emulator.”

8.3 Connecting to a Host with Telnet
 Q: I cannot connect to a host using a Telnet connection, what should 

I do?
 A: Use ping from a command prompt to check for connectivity to 

the host. If you get no response from the host, you have a problem 
with either the network configuration on your machine or your 
network. See your network administrator for assistance.

 Q: Why am I getting Winsock errors (such as, 10065, 10061) when I 
try to connect to a host?

 A: This error comes from Windows, not the TinyTERM emulator. 
Try the following:

 • Open the Network control panel and record all the information 
for the TCP/IP protocol. Remove the TCP/IP protocol and restart 
your machine. Add a new TCP/IP protocol to the Network control 
panel using the information you recorded and restart your 
machine.

 • Visit http://www.sockets.com for details and helpful information 
about Winsock errors.

8.4 Connecting to a Host with a Modem
 Q: My modem dials and it seems like the host is answering, so why 

am I not getting anything on screen?
 A: Try lowering the modem connection speed in the TinyTERM 

emulator.

23
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 Q: When I attempt to make a modem connection, why do I get a 
TAPI error, “No reply from host”?

 A: Make sure that you have typed the phone number correctly, 
without any spaces or dashes in the number. If you need to dial 
9 to get an outside line, you will need to include that in your 
number (for example, 9,18015551212).

 Q: The modem dials, so why do I get the message that there is no 
carrier or the host is not responding?

 A: Check with your UNIX administrator to make sure the host 
system is responding. The UNIX administrator may need to reset 
the modem on the host machine.

8.5 Connecting to a Host Over a Serial 
Connection

 Q: Why don’t I get a response from my host through my serial 
connection?

 A: Try lowering the port connection speed in the TinyTERM 
emulator. Generally, host ports cannot support the 115,200 rate.

 Q: I successfully connected to my host over a serial connection, so 
why can’t I connect a second time?

 A: You probably did not log off properly when you closed the 
connection and left processes running on the UNIX machine. 
Have your UNIX administrator close down any processes you left 
running on the host system and try it again.

 Q: I get the message “connected = RS232,” so why don’t I see a login 
prompt? What’s wrong with my COM port?

 A: Try connecting using Hyperterminal. If Hyperterminal cannot 
connect, check all related cables and connections. Note: If you are 
replacing a dumb terminal with a PC, you will need a null modem 
adapter on one end of the cable between the PC and host machine.
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8.6 Customizing TinyTERM
 Q: How do I get the TinyTERM emulator to automatically connect to 

my host when I start the emulator?
 A: In the Session tab of the Session properties, enter your host name 

or address and click Establish connection on open. You must 
also save the settings to the Default.tpx file or configure the 
TinyTERM emulator to start with your preferred .tpx file.

 Q: Why do I lose my connection to my host system after not using 
the TinyTERM emulator for a while?

 A: Most host systems will automatically close a connection after a 
certain period of inactivity. Your UNIX administrator can set 
how long the UNIX system waits before closing idle connections. 
There are shareware programs on the Internet that will send a 
“keep-alive” packet to keep the connection open.

 Q: Every time I start the TinyTERM emulator, dial-up networking 
tries to connect and I have to press cancel. Can I disable this?

 A: You need to disable the autoconnect feature of your browser or 
dial-up networking. If you use Internet Explorer 4.0, open  
Dial-Up Networking and rename the Internet connection by 
adding one character. Start Explorer, and you see an error 
message. Click the message that disables the autoconnect feature. 
Rename your Internet connection by removing the character you 
added. Note: This is just one example. You may need to contact your 
vendor or ISP to learn how to disable the autoconnect feature.

 8.7 Emulation
 Q: I get strings of letters instead of line-draw characters. What do I 

need to change?
 A: Do the following:
 1. On the Edit menu, click Session Properties.
 2. Click the Session tab, and select Ignore graphic parity bit.
 3. Click the Attributes tab, and select Use non-font based line draw 

characters.
 Q: I have successfully logged in to my host, so why do I see gibberish 

when I run my application?
 A: You have selected the wrong emulation. Check with your UNIX 

administrator to find out what emulation you should be using.
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 Q: I have a hard time reading the TinyTERM emulator’s default 
fonts. How do I change the font?

 A: Do the following:
 1. On the Edit menu, click Session Properties.
 2. Click the Font tab.
 3. If you do not see the font you want to use in the Font/Code Page 

display order list, click Add Font, and choose the font you want 
to use.

 4. Click on the font you want to use, and click Up until that font 
appears at the top of the Font/Code Page display order list.

8.8 Printing
 Q: Why won’t LPR print on the UNIX machine?
 A: Make sure that you have the LPD daemon configured on the 

UNIX host, and make sure your host files are setup correctly 
(remember, UNIX is case sensitive).

 Q: When I try to print from the TinyTERM emulator to my local 
printer, why do I get the following problems?

 • The printer prints garbage
 • The printer prints using very small type
 • The print job does not finish
 A: Check the settings for the printer:
 1. On the File menu, click Printer Setup.
 2. Click Direct to Device.
 3. In the Direct device name box, type lpt1:.
 4. Click Flush output buffer to printer.
 Q: How do I stop my network printer from printing the printer 

codes?
 A: Check the settings for the printer:
 1. On the File menu, click Printer Setup.
 2. Click Direct to Device.
 3. In the Direct device name box, type the full path to your network 

printer (for example, \\server\printer1).
 4. Click Flush output buffer to printer.
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8.9 Map a Network Drive with NFS
 Q: I am connecting to my UNIX host and attempting to map a 

network drive using NFS. Why can’t I complete the mapping to 
the network drive?

 A: Make sure that you have PCNFSD version 2 running on the 
UNIX host.

 Q: I am using NFS on a Windows NT Workstation machine. When 
I’m logged in with Administrator rights, I can shut down the 
machine. Why can’t I shut down the machine when I have logged 
in with User rights?

 A: If you remove the Century NFS component from the machine, 
you can shut down the machine when logged in with User rights. 
We recommend that when installing the TinyTERM emulator on 
a machine where the user will have only User rights that you do 
not install the NFS component.

8.10 Scripting
 Q: I have many scripts written in the TERM Script Language (TSL). 

Can I use these scripts in the TinyTERM emulator?
 A: Yes. TinyTERM provides a built-in script translator that will 

run most of the basic TSL commands. For more information, 
read the TERM Script to CScript Translation Guide. (When you 
installed TinyTERM on your machine, the install wizard created a 
documentation folder on your hard drive that includes the TERM 
Script to CScript Translation Guide.)

8.11 Converting .tap Connection Files
 Q: Can I use my .tap connection files from TinyTERM version 3?
 A: Run the script TAPtoTPX.cs. This will convert a .tap file to a .tpx 

file for use with TinyTERM version 4. For full documentation, 
read the file TAPtoTPX.wri included with TinyTERM.
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9 Contacting Century Software
If you need additional information, visit Century Software’s Web site 
at http://www.centurysoftware.com. At our Web site, you can search 
our Knowledgebase for possible solutions to your problem. From 
our home page, click Support, then click on Knowledge base. If 
you cannot find a solution to your problem in our Knowledgebase, 
contact the Century Software technical support team by  E-mail at 
support@censoft.com or by phone at (801) 268-3088. Before contacting 
Century Software, please collect the following information:

 • Version of the TinyTERM emulator
 • Version of your Operating System
 • Connection Type
 • Emulation
 • File transfer protocol used (if applicable)
 • Description of your problem
 • Steps to duplicate your problem
 • Any error messages you received
 • Type of printing you use (such as LPD, LPR, transparent)
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